Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 21, 2025 - 07:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 21, 2025 - 06:41 UTC
Scheduled
We will be updating our systems. Some users may experience temporary issues accessing the platform during that time, but trading will remain unaffected.
Posted Jun 11, 2025 - 15:04 UTC
This scheduled maintenance affected: WL Server 1 (Dubai) (User Authentication, Price Quotations, Candles, Open/Close, Take Profit/Stop Loss, Pending orders, Positions Listing, Transactions/Finance History, Copy Trading), WL Server 2 (London) (User Authentication #2, Price Quotations #2, Candles #2, Open/Close Position #2, Take Profit/Stop Loss #2, Pending orders #2, Positions Listing #2, Transactions/Finance History #2, Copy Trading #2), and Prop WL Server (User Authentication #3, Price Quotations #3, Candles #3, Open/Close Position #3, Take Profit/Stop Loss #3, Pending orders #3, Positions Listing #3, Transactions/Finance History #3, Copy Trading #3).