System Maintenance - Platform - Prop WL Server

Scheduled for Nov 29, 08:00 - 09:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Nov 21, 2025 - 12:07 UTC

Scheduled

We will be updating our systems. During the maintenance window, users may experience temporary issues accessing the platform.
Posted Nov 21, 2025 - 12:02 UTC
This scheduled maintenance affects: Prop WL Server (User Authentication #3, Price Quotations #3, Candles #3, Open/Close Position #3, Take Profit/Stop Loss #3, Pending orders #3, Positions Listing #3, Transactions/Finance History #3, Copy Trading #3).